Header Image - Our Group Has Been Designed By The Community

Category Archives

10 Articles

Network Status February 2020

We start 2020 off with high hopes to get our Telegram group growing to try to have all members of the WUG network to be part of the group, there are very few unrelated messages to the WUG, no spam is tolerated and is deleted within minutes, we try to change the group photo to that of the wiki’s “Highsite of The Day”, but are not always able to keep it updated. This group does not have spam, it is there for only WUG-related issues, anyone is welcome to send a message regarding issues they are having and admins will help them ASAP. You might have the same problems or will experience the same problems one day – you can learn a lot! There are under 10 messages per day (average over the last year) and are specifically WUG related such as for example “Johan Slabbert (admin): NW is UP! And connected to the rest of the WUG again.” sent the day before this post was written, and similar messages.


In 2019 we were able to get a lot of old WUG users who were no longer on the WUG due to some of the following reasons:

  • Frequency list to scan being set incorrectly to a single frequency which the sector might have used in the past but is no longer using.
  • Country not being set after ROS & firmware upgrades, preventing the radio from connecting.
  • The protocol set to a single protocol that the highsite is no longer using, so changing the protocol to any fixed this.
  • Sending instructions to users on how to set up new computers they have bought that are not connected to the WUG.
  • Providing users with instructions to configure their computers to allow both internet and WUG, as some users had to choose the internet over WUG and were not aware that it’s very easy to have both on a device.
  • Having users re-align their grids after many years where it was last aligned, which are no longer aligned properly due to weather, birds and multiple other factors.
    • Psst. A trick to get birds off of your grid is to put thick cable ties at the top part between each section of the grid and cutting the cable ties short and at a sharp angle preventing birds from being on top of your grid.
  • Helping users move to highsites we have created since previous ones that they were connected to were decommissioned.
  • Users who no longer used the WUG because of very slow speeds, and us recommending to users who have highsites that support dual polarity (and even ones that don’t) to upgrade from over a decade-old system of a RouterBoard + Radio + Pigtail + LMR + Grid (or Groove + Grid) to upgrade to light head grids (LHGs) that are dual-polarity, support 20mhz/40mhz(/80mhz) channel width, as well as low noise and wireless-n support. An all-in-one system where a powerful radio is built into the dish-like grid already, and you simply need to run a POE cable to it.
    • This helped a lot in most cases, didn’t help in some (those being where LOS is still not good as well as extremely long distances (7-10km+), in those, that it helped the best that I (shock) have personally seen is a user I helped in Valhalla, who had a 0.7mbit/s connection with a Routerboard + Radio + Pigtail + LMR + Grid, who bought himself a LHG upon my recommendation and his connection had become a lot better with an average of 6mbit/s constantly, a peak of 16-20mbit/s, and a low of 2.5mbit/s, CCQ was 100%, but with the previous equipment it was 30%. The connection was stable and did not drop once but with the previous equipment, it would drop at least 20 times an hour.
    • Disclaimer: Upgrading kit does not guarantee any speed improvements, the highsite also needs upgrades – which requires donations.
  • Many other ways to get users WUGGED again after they have not been WUGGED for years!

This is due to the tireless effort from all of the PTAWUG staffdonations from members of the WUG as well as from the staff and our new way of interacting with users through our Telegram group which is linked to the IRC server. In the past, there used to be two admins on IRC and not online always, users would join, ask for help and explain their situation, and then instead of waiting an hour or two for a response when those admins on IRC were able to, they usually left after 5-10 minutes since when they connected. Now when you join IRC your messages get relayed to our Telegram group with a lot of staff members, go2guys and WUGGERS – we respond within 5 minutes at any time during the day and up until late at night, we try our utmost best to help you through this chat relay. We do also make sure to mention to the users that we have a Telegram group and that they can get hold of us there at almost any time.

The Network Status layout will be changing for 2020, it will now be posted monthly – instead of at the end of each month it will now be posted once a month the first time there is a big change on the network – and anything else afterward will be in the next post. It will no longer be a detailed analysis regarding certain problems but will be almost like a copy of the whole “Network Status” section in the center widget of the home page.


Here is the Network Status for January and Mid-February:

Good News:

NW is now back up and running on the WUG! Thanks to jasweb and all those involved in getting this fixed, and to everyone who donated which has made this possible! Remember that kit costs money, and without donations, PTAWUG can not replace, upgrade or repair broken kit!

RL’s backbones have been fixed and/or replaced, excluding the one to SO, which is currently a very high priority. The sectors are still down but we are working with the property owner to be able to see what we can do.

Bad News:

North<>South are separated due to Basden (BD) having to be decommissioned. 

The only links between the North<>South is via TN*.

If anybody, whether you’re a WUG user or just a person reading here, if you have a line of sight between the north and south of Pretoria, or to the Unitas Hospital, please contact [email protected] or [email protected] directly.

RL (Raslouw) needs some serious maintenance and repairs, and we will be needing a LOT of donations and man-hours to handle the work. No matter what you’re good at, we will definitely appreciate any and all help. RL connects important highsites in Pretoria together and has a capacity for a very high throughput of data

*TN, also referred to as Teraco Network, is where we use our own personal internet and tunnel the WUG traffic to a central server kindly provided by JAWUG, and it is currently fully at capacity on the side of TN nodes – meaning that more highsites are needed to be connected so that traffic can be distributed easily. If there are any highsite owners with fibre >= 10mbit/s please contact shocksilver or any other PTAWUG staff.

 

R.A.S.P. Notice for PCSectorN

R.A.S.P. Important Notice:

Those users on PCSectorN who have not registered yet please open a browser to 172.25.250.5. This will get your connection up and running and will allow us to make sure your connection is working well!

 

Please make sure to email [email protected]wug.za.net also if you are struggling and make sure to join our telegram group at https://t.me/FDUjwQwJI4DIN87ru0_FQg .

Amateur “Ham” Radio

by JP Coetzee 0 Comments

What is Amateur “Ham” Radio:

Amateur Radio is a great way to learn about communications technology and make friends all over the world. Getting involved in this fascinating hobby is very easy and won’t cost an arm and a leg.

Radio Amateurs, or “hams” use two-way radio communication to make contact with other radio amateurs all over the world. They are even able to use satellites and on occasion speak with astronauts. The wonderful thing is that a radio amateur can do this from home, or while mobile in cars, boats or on foot.

What Do They Have:

Radio Hams have a full range of communication modes at their disposal. These include plain voice, Morse code, numerous digital computer modes and even graphical modes like television. As a licensed amateur radio operator you will be able to join in experiments using all these modes.

Amateur radio can be enjoyed by young and old, male and female, even the most severely disabled can make friends around the world from their own home. This hobby knows no boundaries.

Using even the simplest of radio setups and antennas, amateurs communicate with each other for fun, during emergencies, and in contests. Through Hamnet, they may be called upon to handle messages for police and other public service organisations during all kinds of emergencies.

http://w2wcr.org/Members/KD2BVA/broadband-hamnet-hsmm-mesh-photos/a-hypothetical-mesh/@@images/c1fd43cf-dc9e-4042-a3f9-f1348bc70e1d.jpeg

A mesh with broadband Hamnet and how one can immediately see the similarity to PTAWUG’s mesh layout.

How to Get Your License:

Because radio amateurs are permitted to use a wide range of frequencies and types of transmission, they must be qualified operators. In South Africa like most countries around the world, Amateur Radio is regulated by the Government Department of Communication and licensing is dealt with by the Independent Communications Authority of South Africa (ICASA).

South African regulations require you to write a small exam, which is set to test your understanding of the basic principles of radio and the regulations governing amateur radio operators.

The Exam:

This exam is simple enough for anyone with high school education and an interest in the hobby to pass. In most cities and towns around the country and there are also clubs that provide classes for the RAE and facilitate the writing of the test.

For more detailed information about exams contact Vincent Harris @ 012-998-8165 Cell 083-754-0115 or Fritz Southerland @ 012-811-3875 cell 083-304-0028.

Activities Hams Take Part Of:

  • Rallies.
  • Fox Hunting. (not that type of one!).
  • Regular Contests.
  • Satellites like these.
  • D-Star (Digital Radio).
  • IRLP (VoIP).
  • Echo Link (VoIP).
  • Broadband Hamnet – find more info here.
  • Club Meetings and Get-togethers.
Related image

Basic Broadband Hamnet setup:

Amateur Radio Swapshops and Fleamarkets:

Swop Shop – Hans ZS6KR is the guy that handles the swops 012-333-2612.

Radio amateurs regularly get together to swap and buy equipment, obtain components for projects and socialize to chat/brag about their latest achievements in radio communication or contests.

Venues for such activity are club meetings, amateur fleamarkets and making use of the club website swap pages. Most dealers also advertise here or on the South African Radio League (SARL) swap page at especially if they have second-hand equipment to dispose of.

Image result for amateur radio flea market

An example of a flea market:

As there are various clubs in the Highveld area there is always a choice of fleamarket to go to on a regular basis. Last but not least, on-the-air offers-and-wants session that takes place every Sunday morning after the Pretoria Club news bulletin on 145,725 MHz and 7,066 MHz.

Note: This article has been modified from the original wiki article located at http://172.24.1.1/mediawiki/index.php/Amateur_Radio and that all credits go to the original author RM (aka “RadioMan”).

How to Limit the Bandwidth Speed for a User After A Cap Has Been Reached

by JP Coetzee 0 Comments

This is not used on the WUG, so do not worry about it!


Based on https://wiki.mikrotik.com/wiki/Limiting_a_user_to_a_given_amount_of_traffic_II

Modified the script for Cavelynx to help manage his internet users at a guest house. Fixed for latest ROS (6.41), added variables.

First create the simple queues you need (create script, run ONCE only):

:for e from=20 to=253 do={
/queue simple add name="user $e" target="192.168.1.$e" queue=default/default total-queue=default
}

Then create a schedule to run this daily (23:59):

/que simple reset-counters

The script itself I’d recommend running every 5-20 minutes, depending on your RB’s CPU(s):

:local traf;
:local throttledSpeed;
:local unthrottledSpeed;
:local cap;

# cap in megaBYTEs
:local theCap 200;
# speed limit in megaBIT/s
:local throttledSpeedLimit 5;
:local unthrottledSpeedLimit 20;
:local upThrottledSpeedLimit 5;
:local upUnthrottledSpeedLimit 20;

# the ip range to use
:local cLevel 1;
:local startRange 20;
:local endRange 253;

:local dTemp ($throttledSpeedLimit * 1000000);
:local uTemp ($upThrottledSpeedLimit * 1000000);

:local eTemp ($unthrottledSpeedLimit * 1000000);
:local vTemp ($upUnthrottledSpeedLimit * 1000000);

:set throttledSpeed  "$dTemp/$uTemp";
:set unthrottledSpeed "$eTemp/$vTemp";
:set cap  ($theCap * 1000000 * 8);

/queue simple
  :for i from=$startRange to= $endRange do={
    :if ([/queue simple find target=("192.168." . $cLevel . "." . $i . "/32")] != "") do={
      :set traf [get [find target=("192.168." . $cLevel . "." . $i . "/32")] total-bytes]
# limit people who have reached the "cap"
      :if ($traf  > $cap) do={
:log warning "User $i has reached cap, throttling."
        set [find target=("192.168." . $cLevel . "." . $i . "/32")] max-limit=$throttledSpeed
      }
# we still want to limit people who have not reached the "cap"
      :if ($traf  < $cap) do={
        set [find target=("192.168." . $cLevel . "." . $i . "/32")] max-limit=$unthrottledSpeed
      }
    }
  }

RL & RF Issues

by JP Coetzee 0 Comments

We are aware about the issues at RL and RF, there is a new owner at RL who we are currently speaking with to be able to access the site. RF we are not yet aware of the issue but might be fixed when RL comes back online.

– shock

May Network Status

Network status brings the following:

The users page reports 84 unique routerboards excluding highsite routerboards, in general families use the wug together so this is not much of an issue but it has decreased from 93 last month.

The users not connected in two days is 66, which is between two and six months. We are working to get these users “back” and once not only these are back to start expanding again.

We require a Facebook and Twitter page manager, along with all other types of social networks. Anybody, do not be afraid of it – we welcome any of you PTAWUG members to help us once again.

PTAWUG Constitution

by admin 0 Comments
PTAWUG Constitution

THE CONSTITUTION OF PRETORIA WIRELESS
USER GROUP (PTAWUG)

PTAWUG

PTAWUG – Pretoria Wireless User Group

We, the WUG, hereby pronounce this document and its content
as our Constitution, that we will endeavour to abide by it, and
that we instate it as the only legal, enforceable and valid
agreement between the WUG and its members.
This constitution sets out the objectives, organization and general
conduct of PTAWUG, which is based upon democratic, fair, equal
and dignified principles and every member is required to read and
abide by the principles set out herein.

1. Definitions

1.1

A “WUG member”, “wugger” or “member” in this constitution shall be any person who has the animus or mindset to be part of the WUG, makes use of the WUG, or actively participates in the activities of the WUG.

1.2

The “WUG” or “wireless user group” shall be Pretoria Wireless User Group as well as any of its members.

1.3

The primary communications medium shall for all purposes be Internet Relay Chat (IRC), within the set out channels on the specified server. The usage of any other means of communication by members shall not be deemed official in terms of this constitution unless the contrary is proved.

1.4

An official WUG decision shall be any decision taken by, attempted by, proposed by or affected by any person or group of people, claiming to be taking, attempting, proposing or affecting the decision. This is in the capacity as representative or member of the WUG.

1.5

A “Highsite” as referred to in this constitution shall be a single location where donated equipment is installed in order to connect multiple members to a single entry point into the network and at the same time provide connectivity to the rest of the network.

PTAWUG April Network Status

PTAWUG April Network Status
favicon

Network status brings the following:

The users page reports 93 unique routerboards excluding highsite routerboards, in general families use the wug together so this is not much of an issue but it has increased from 75 last month.

The users not connected in two days is 73, which is between two and six months. We are working to get these users “back” and once not only these are back to start expanding again.

We require a Facebook and Twitter page manager, along with all other types of social networks. Anybody, do not be afraid of it – we welcome any of you PTAWUG members to help us once again.

PTAWUG on Google Groups – What Went Wrong

Many of the posts on Google Groups have not been answered. While I would like to answer each one of them I do not currently have the time and I will just be “bumping” dead posts.
So here’s what I would like to provide you with info as there has been a LOT of confusion regarding who to contact for what. In a short summary I will provide infomation on what’s still left of the WUG. Your posts and the reason there is/was no response. Where you can get IMMEDIATE support easily for wug-related stuff. Who to contact when desperate. Who the administrators are. What the plans for the WUG are in the future.